cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to get php.ini or .user.ini to work

I've contacted support about this but nothing has been fixed. I am currently trying to setup a wordpress theme I have on cpanel and all is going well apart from uploading the plugins I need to as I get this error:

The uploaded file exceeds the upload_max_filesize directive in php.ini.

 

I contacted my theme provider and they have recommended these settings for my php.ini and recommended contacting my host to do this for me as I'm on shared hosting:

memory_limit 256MB
max_execution_time 180
max_input_time 60
file_uploads On
max_file_uploads 20
post_max_size 32MB
upload_max_filesize 32MB

 

This has not worked and godaddy has tried using both php.ini and .user.ini and nothing has worked. Sometimes I can't get to certain pages on wordpress or logout of it because I get a 500 error. Does anyone have any idea of what the issue is or how to solve this as it's getting a bit frustrating now.

4 REPLIES 4
Helper V

Re: How to get php.ini or .user.ini to work

@Imperious

 

So if I understand this correctly ,

In your file structure in your cpanel you can physically see the php.ini file with the code you were given written into the file?

You have, "show all files", clicked so you can see all the files?

Check the file yourself 🙂

-------------------

You can,

Make a phpinfo file , phpinfo.php or anything you like .php

Add <? phpinfo(); ?> to the file,

Open the file, yourdomain.com/phpinfo.php or whatever, check the file to see if the changed took. Then you have more information to give to godaddy support .

 

Hopefully this has helped out some?? 

Mrsroadrunner Photography

Re: How to get php.ini or .user.ini to work

@mrsroadrunner

 

There was no php.ini in my cpanel so I had to make the file myself but it doesn't seem to be doing anything.  I have 'show all' on the settings when I open up my cpanel.

 

I had a look and it hasn't taken the information from the php.ini file or from .user.ini, Thanks for the assistance though.

Helper V

Re: How to get php.ini or .user.ini to work


@Imperious wrote:

@mrsroadrunner

 

There was no php.ini in my cpanel so I had to make the file myself but it doesn't seem to be doing anything.  I have 'show all' on the settings when I open up my cpanel.

 

I had a look and it hasn't taken the information from the php.ini file or from .user.ini, Thanks for the assistance though.


@Imperious

 

Hi there,

Take this information to godaddy support. Sounds like they are changing the wrong file for you 🙂

There is more then one of these files on a server, the trick is to find the right file!

Hope you get this figured out,

Coralie

Mrsroadrunner Photography
Employee
Employee

Re: How to get php.ini or .user.ini to work

The filename you use is situational, but the one that works on all hosting plans with php 5.4 or newer is .user.ini

There's an issue with the code you posted, you need an equal sign with the settings, such as

memory_limit = 256MB