cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

SSL on a Godaddy Wordpress site secured by Sucuri Pro Plan

Hi,

First I registered a domain at Godaddy, then I signed up with Sucuri and got it set up, then I bought an SSL cert through Godaddy.

 

Now when I try to login to wp-admin I get a "too many redirects" error.  

 

If you'd like to try, the domain name is https://www.discrimination.today/.

 

It hasn't been 72 hours since I got the SSL, so maybe this is a propagation timing issue.  Or maybe I should use the SSL cert at Sucuri instead of at Godaddy.

 

What do y'all think?

 

Thanks in advance!

1 REPLY 1
Helper V
Helper V
Solution

Re: SSL on a Godaddy Wordpress site secured by Sucuri Pro Plan

@boydstone I checked your site and found the problem.

I looks like you are redirecting https://www.discrimination.today/ to https://discrimination.today/ 

then you are redirecting  https://discrimination.today/  to  https://discrimination.today/  causing the endless loop.

 

Request URL:https://discrimination.today/
Request Method:GET
Status Code:302 
Remote Address:192.124.249.18:443
Response Headers
content-length:213
content-type:text/html; charset=iso-8859-1
date:Thu, 05 Jan 2017 18:48:32 GMT
location:https://discrimination.today/
server:nginx
status:302
x-content-type-options:nosniff
x-frame-optionsSmiley FrustratedAMEORIGIN
x-sucuri-id:11018
x-xss-protection:1; mode=block
Request Headers
:authority:discrimination.today
:method:GET
Smiley Tongueath:/
:scheme:https
accept:text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
accept-encoding:gzip, deflate, sdch, br
accept-language:en-US,en;q=0.8
cache-control:max-age=0
cookie:sucuri_cloudproxy_uuid_a7596aee1=4b958c71ddac726a8456c2d8a5ef081e
upgrade-insecure-requests:1
user-agent:Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

The redirect is taking place on the webserver and was most likely cause by attempting to redirect the HTTP(Non secure) to the HTTPS(Secure). 

Depending on what webserver you are using and whether you and/or Sucuri is doing the redirect.

 

It looks like Nginx webserver is sending the 302 redirects. I would first check with Sucuri to see if they are doing the redirects next would be to check your webhost for redirects.