Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Uploading a PDF file to website

I've searched the community and can't find an answer to my specific question. I've uploaded PDF files to my media library in the past with no problem on several websites. Suddenly today I've noticed that several PDF files have disappeared -- a few are still there and a few are gone. I see a message "not allowed filed extension." I don't know when they disappeared, sometime in the past few months.


Are PDF files suddenly not allowed? These are not huge files, they're significantly below the file size limit, in some cases just a couple of pages.


I'm on Business Hosting, using cpanel. 

Super User I Super User I
Super User I

Re: Uploading a PDF file to website

Missing files out of nowhere is not a normal thing on your hosting @laurahk. What kind of scanning and monitoring are you doing? 


The simple answer is you should be able to upload PDF files into your hosting structure. Are you uploading directly to your hosting or are you using a content management system like WordPress? I would not expect that GoDaddy removed any files without reason and notification (if that occurred). 


...turns out that my two cents is worth less or more depending on the current exchange rate.

roy darling *my posts seem a lot shorter in my head


Re: Uploading a PDF file to website

Thank you, rd. I'm glad to know I'm not crazy, that it's still normal to upload pdfs. I had some time a little while ago so I did a chat session with a GoDaddy tech person. He was able to figure out that somehow in my PHP version "pdf" as an allowable extension had become unchecked. I know I didn't do that -- I haven't changed the PHP version recently, so I haven't even been on that page in the cpanel for many months. Once I re-checked "pdf" and waited a few minutes, I was able to upload pdf files to the media library as I have in the past. The files that have disappeared are gone, and I will need to re-upload them, but at least it is fixed now.