• GoDaddy Community
  • Websites + Marketing | Website Builders
  • Websites + Marketing | Website Builders

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    Helper I

    installed Joomla 2.5 and its not even mobile friendly

    Hi, I have installed Joomla from the GoDaddy product section. I have spent ages setting my site  up and when I run Google mobile friendly it says my site is not Mobile friendly. So I went through all the templates GoDaddy supply Joomla with and none are mobile friendly. So I went on the net looking for templates and found a few. The problem is most that are mobile friendly are for Joomla 3, But GoDaddy gave me Joomla 2.5. Anyway it seems if I wanted Joomla 3 I would have a problem in that the php version GoDaddy give us is not new enough for Joomla 3.

    I love the way Joomla works but need a site that is compatible with todays market. That to me means it should be mobile friendly. Can anyone here help me out. My site is mathswhizz.org I have been hosting one site or another with GoDaddy for quite a few years now. I just feel a little let down they are not supplying new software.

    Thanks Nige

    1 ACCEPTED SOLUTION

    Joomla 2.5 has been end of life since 2014 so you should not be investing any time or effort on a version of the software that has been superseded. It is much better to install Joomla 3.5 which you can do by following the instructions at: https://docs.joomla.org/J3.x:Installing_Joomla

     

    Joomla 3.5 needs a minimum of PHP 5.3 but it's probably better to run it on PHP 5.6 or 7.0 right now. If your GoDaddy hosting account does not support PHP 5.3 or later then you should probably look for another hosting company. Log in to cPanel and look for the PHP Selector tool to see what PHP versions are available.

     

    I would not recommend sticking with Joomla 2.5 but if you choose to do this, make sure you update to the latest version 2.5.28 and install the end of life patches which you can find at https://docs.joomla.org/Security_hotfixes_for_Joomla_EOL_versions. There are a few free responsive templates e.g. RocketTheme Gantry template which you can find at http://gantry.org/downloads#g4-joomla

    View solution in original post

    4 REPLIES 4
    Retired
    Not applicable

    Hi @Mike12,

     

    A VPS and you can install what you like! 

    You have clearly got more money than me.

    I will settle for a link to a Joomla 2.5 template that is mobile friendly out the box. I would also like to know if GoDaddy intend on updating the software? so people get an up2date Joomla when GoDaddy installs it. If they are planning it when?

    🙂 till then I will keep surfing the net looking for a free template that is mobile friendly.

    Joomla 2.5 has been end of life since 2014 so you should not be investing any time or effort on a version of the software that has been superseded. It is much better to install Joomla 3.5 which you can do by following the instructions at: https://docs.joomla.org/J3.x:Installing_Joomla

     

    Joomla 3.5 needs a minimum of PHP 5.3 but it's probably better to run it on PHP 5.6 or 7.0 right now. If your GoDaddy hosting account does not support PHP 5.3 or later then you should probably look for another hosting company. Log in to cPanel and look for the PHP Selector tool to see what PHP versions are available.

     

    I would not recommend sticking with Joomla 2.5 but if you choose to do this, make sure you update to the latest version 2.5.28 and install the end of life patches which you can find at https://docs.joomla.org/Security_hotfixes_for_Joomla_EOL_versions. There are a few free responsive templates e.g. RocketTheme Gantry template which you can find at http://gantry.org/downloads#g4-joomla

    View solution in original post

    Thanks for a super answer